[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677

hyatt hyatt at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 07:21:02 UTC 2009


The following commit has been merged in the debian/unstable branch:
commit 317fa09c5dcbbd1e887c6874fddf27766991e9c3
Author: hyatt <hyatt at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Wed Jan 22 19:23:01 2003 +0000

    	Fix for 3153316, selection busted on google.com.  For now keep
    	mouse events grabbing the absolutePosition of elements, and don't
    	ever let them grab the absolutePosition of text nodes.
    
            Reviewed by john.
    
            * khtml/khtml_events.cpp:
            (khtml::MouseEvent::MouseEvent):
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@3399 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog-2003-10-25 b/WebCore/ChangeLog-2003-10-25
index 452c759..84ded05 100644
--- a/WebCore/ChangeLog-2003-10-25
+++ b/WebCore/ChangeLog-2003-10-25
@@ -1,3 +1,14 @@
+2003-01-22  David Hyatt  <hyatt at apple.com>
+
+	Fix for 3153316, selection busted on google.com.  For now keep
+	mouse events grabbing the absolutePosition of elements, and don't
+	ever let them grab the absolutePosition of text nodes.
+	
+        Reviewed by john.
+
+        * khtml/khtml_events.cpp:
+        (khtml::MouseEvent::MouseEvent):
+        
 2003-01-22  Chris Blumenberg  <cblu at apple.com>
 
 	Renamed isPointSelected to isPointInsideSelection because it's a better name.
diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index 452c759..84ded05 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,3 +1,14 @@
+2003-01-22  David Hyatt  <hyatt at apple.com>
+
+	Fix for 3153316, selection busted on google.com.  For now keep
+	mouse events grabbing the absolutePosition of elements, and don't
+	ever let them grab the absolutePosition of text nodes.
+	
+        Reviewed by john.
+
+        * khtml/khtml_events.cpp:
+        (khtml::MouseEvent::MouseEvent):
+        
 2003-01-22  Chris Blumenberg  <cblu at apple.com>
 
 	Renamed isPointSelected to isPointInsideSelection because it's a better name.
diff --git a/WebCore/khtml/khtml_events.cpp b/WebCore/khtml/khtml_events.cpp
index 706a571..98afc23 100644
--- a/WebCore/khtml/khtml_events.cpp
+++ b/WebCore/khtml/khtml_events.cpp
@@ -35,8 +35,14 @@ khtml::MouseEvent::MouseEvent( const char *name, QMouseEvent *qmouseEvent, int x
   m_url( url ), m_target(target), m_innerNode( innerNode )
 {
   d = 0;
-  if (innerNode.handle() && innerNode.handle()->renderer())
-      innerNode.handle()->renderer()->absolutePosition(m_nodeAbsX, m_nodeAbsY);
+  if (innerNode.handle() && innerNode.handle()->renderer()) {
+      // FIXME: For text nodes, for now, we get the absolute position from
+      // the parent.
+      DOM::Node n = innerNode;
+      if (n.nodeType() == Node::TEXT_NODE)
+        n = n.parentNode();
+      n.handle()->renderer()->absolutePosition(m_nodeAbsX, m_nodeAbsY);
+  }
 }
 
 khtml::MouseEvent::~MouseEvent()

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list