[sane-devel] sane backend build system - help

Chris Bagwell chris at cnpbagwell.com
Sun Apr 24 18:15:35 UTC 2011

Its common to have a newer version of autofoo tools on your system and
you'll need to update the pre-existing files committed in git.

Try running with install option to get newer versions of files: autoreconf -i

If that doesn't work then use the force option:  autoreconf -i -f


On Sun, Apr 24, 2011 at 10:17 AM, Paul Newall <p.newalls at ntlworld.com> wrote:
> I want to write a new backend.
> Currently the main obstacle is that I find the backend build system very
> intimidating.
> I have no experience of autoconf, automake, or libtool.
> On my system (ubuntu 10.10) I can run autoreconf and ./configure apparently
> OK, but when I run make I get these errors:
> libtool: Version mismatch error.  This is libtool 2.2.10, but the
> libtool: definition of this LT_INIT comes from libtool 2.2.6b.
> libtool: You should recreate aclocal.m4 with macros from libtool 2.2.10
> libtool: and run autoconf again.
> make[2]: *** [libsane_la-dll-s.lo] Error 63
> How would I recreate aclocal.m4 with macros from libtool 2.2.10 ? I don't
> have much idea what that means.
> Is it best to start by adding an empty new backend to the build system? (in
> which case I will need to get the build system to work first)
> Or would it be better to make and install  the new backend independently
> during development? (this might be easier? and it might give me a faster
> modify, build, test cycle during development? But are there difficulties
> that I have not discovered yet?)
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list